1. Set up router management information
1. Connect the 9-hole connector with a flat control line, connect CONSOLE to the terminal or PC serial port, and set the parameters of the terminal or super terminal directly connected to the serial port: BAND rate 9600, no parity, 8-bit data bits, 1-bit stop bit.
2. When the router is powered on, the terminal screen will display the power-up process.
3. Enter privileged mode to set password
line vty 0 4
password bc123
exit
enable secret bc123fzq123
exit
4. Set router information in privileged mode:
hostname bc3640
ip domain-list
ip domain-list
ip domain-name
ip name-sever 10.54.34.1
5. Enter global mode and configure the Ethernet address
configure timinal
interface fastethernet 0/0
ip address 192.168.254.254 255.255.255.0
no shutdown
exit
interface fastethernet 1/0
ip address 10.154.34.253 255.255.255.252
noshut down
exit
Set the IP routing function to open
ip routing
Set dial-in customer name and password
username user1 password 123
Set dial group parameters and specify the IP address for dialing customers
line 65 72
autoselect ppp
modem inout
transport inputall
exit
interface group-async1
ip unnumbered fastethernet 1/0
encapsulation ppp
dialer in band
dialer map ip 10.154.34.247 name user 1
async default routing
anync mode interactive
peer default ip address pool default
ppp authentication chap pap
group-ranger 65 72; Router remote dial-in port
Set up internal ospf routing protocol and static routing
access-list 77 permit 10.154.34.0 0.0.1.255
router ospf 110
redistribute connected subnets
redistribute static subnets
passive-interface fastethernet 0/0
network 10.154.34.0 0.0.255 area 0
network 10.154.35.0 0.0.0.255 area 0
distribute-list 77 out
exit
ip default-gateway 10.154.34.254
Ip router 0.0.0.0 0.0.0.0 10.154.34.254
Ip router 10.0.0.0 255.0.0.0 10.154.34.254
Ip router 192.168.0.0 255.255.0.0 192.168.254.1
Setting up NAT conversion
access-list 99 deny 192.168.3.1
access-list 99 permit 192.168.3.0 0.0.0.255
access-list 99 permit 192.168.0.0 0.0.255.255
ip nat pool netdyn 10.154.35.1 10.154.35.126 netmask 255.255.255.0
ip nat inside source list 99 pool netdyn overload
ip nat inside source static 192.168.3.1 10.154.35.1
interface fastethernet1/0
ip nat outside
exit
interface group-async1
ip nat outside
exit
interface fastethernet 0/0
ip nat insider
exit
write memory
2. CISCO router WAN configuration wizard
1. dial-on demand routing (ddr) is a network connection provided by a public telephone network. Generally, most WANs are connected using dedicated lines. The routers are connected to DCE devices similar to MODEM OR ISDNTAS. They support synchronous V.25BITS protocol, and you can set the dial string using the SCRIPTS AND DIALER command.
DDR is more suitable for situations where users have low logarithmic requirements, occasionally data transmission or just data transmission at a specific time, such as bank reports every night, etc.
When a packet of interest arrives at the router, a DDR request is generated. The router sends call establishment information to the DCE device of the specified serial port. This call connects the local and remote devices. Once there is no data transmission, the idle time starts to be recorded, and the set time is exceeded, and the connection is terminated. DDR now uses static routes to transmit data to avoid DDR dialing caused by routing exchange.
and XNS can be addressed through DDR routing, synchronous serial port, asynchronous serial port and ISDN port can be configured for DDR connections to one or more destinations.
Here is a typical DDR connection:
During the process of configuring DDR, we can configure one or several physical ports into a logical dialing interface, which can be synchronized V.25, synchronized DYR start dialing or asynchronous CHATSCRIPT mode.
In port configuration mode:
Activate DIAL-ON-DEMAND ROUTING on one port
Command: dialer in-band
Specify a port as a dialer-group-number
Specify a single phone number: dialer string dialer-string
Unprecedented waiting time before disconnection: dialer idle-time seconds
Define one or more destination phone numbers tables:
dialer map protocol net-hop-address dialer-string
Qualify the access-list table or specific protocol for transmission:
dialer-list dialer-group list access-list-number or
dialer-list dialer-group protocol protocol name(permit/deny/list access-list-number)
Specific configuration:
!
interface serial 0
ip address 131.108.126.1 255.255.255.0
dialer in-band
dialer-group 1
!
dialer map ip 131.108.126.2 55551234
!
dialer idle-timeout 300
dialer backup example
A) Synchronize V.25bits method
configuration for routerA:
interface serial 10:0
backup delay 0 10
backup interface serial 110
ip address 16.217.30.2 255.255.255.252
!
interface serial 110
ip address 16.30.16.81 255.255.255.25.0
encapsulation ppp
dialer in-band
dialer string 8292
dialer-group 1
pulse-time 1
!
dilar-list 1 protocol ip permit
B) Auxiliary port for dialing backup
configuration for routerA:
chat-script mydial “””atdt 8292” timeout 60 “connect”
!
interface serial 0
backup delay 0 0
backup interface async1
ip address 16.3.1.1 255.255.255.0
encapsulation ppp
!
interface async1
ip address 16.3.2.1 255.255.255.0
encapsulation ppp
keepalive 9
async default routing
async dynamic address
async dynamic routing
async mode dedicated
dialer string 8292
dialer-group 1
!
dialer-list 1 protocol ip permit
!
line aux 0
script dialer mydial
modeinout
transport output none
stopbits 1
flowcontrol hardware
speed 9600
subinterface example (frame realay)
configuration for routerA:
interface serial 0
encapsulation frame-relay
interface serial 0.1 multipoint
ip address 11.10.11.1 255.255.255.0
frame-relay interface-dlci 41
frame-relay interface-dlci42
[1][2][3] Next page
Article entry: csh Editor in charge: csh
configuration for routerC:
interface serial 0
encapsulation frame-relay
interface serial 0.1 point-point
ip address 11.10.16.2 255.255.255.0
frame-realy interface-dlci 46
configuration for routerB:
interface serial 0
encapsulation frame-relay
interface serial 0.1 multipoint
ip address 11.10.11.3 255.255.255.0
frame-relay interface-dlci 43
frame-relay interface-dlci 44
!
interface serial 0.2 point-point
ip address 11.10.13.1 255.255.255.0
frame-realy interface-dlci 48
frame relay switching example
configuration for routerA:
frame-relay switching
no ip address
frame-relay encapsulation
frame-relay route 163 tun0 43
frame-relay intf-type dce
!
interface serial0
ip address 131.108.100.1 255.255.255.0
!
interface tu 0
tunnel source serial 1
tunnel destintion 131.108.13.2
configuration for routerB:
frame-relay switching
!
interface serial 0
no Ip address
frame-relay encapsulation
frame-relay router 9 tun0 43
frame-relay interface-type dce
!
int tu 0
tunnel source serial 1
tunnel destination 131.108.100.1
Previous page [1][2][3] Next page
Article entry: csh Editor in charge: csh
channelized E1interface example
Assume it is a 7500 series router, the E1 interface (MIP board) is on the slot 4.
A CHANNEL-GROUP can correspond to multiple time slots. In this example, SERIAL4/0:1 has a 5*64 rate.
configuration for router :
controller e1 0
framing no-crc4
chanel-group 0 timeslots1
channel-group 1 timeslots 2,7-9,20 speed 64
!
interface serial4/0:0
Ipaddress 16.217.30.2 255.255.255.252
Encapsulation ppp
!
interface serial 4/0:1
ip address 16.205030.5 255.255.255.252
X.25 EXAMPLE
When configuring X.25, static routing is usually used to reduce calls caused by routing switching, while in one-to-many cases, subinface is not configured in a subnet
configuration for router:
interface serial 0
ip address 131.108.100.1 255.255.255.0
encapsulation X.25
X.25 address 041673226839
x.25 htc 16
x.25 map ip 131.108.100.2 041675222222
int s 0.1
ip address 131.108.101.1 255.255.255.0
x.25 mapip 131.108.101.2 041674222222
!
ip router 131.108.100.0 255.255.255.0 131.108.100.2
ip router 131.108.101.0 255.255.255.0 131.108.101.2
Previous page [1] [2][3]
Article entry: csh Editor in charge: csh